summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-06 00:41:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:01 -0400
commit5e25aeee162d88fd2a7c9254a3b3df1783e1b69b (patch)
tree4f604e96ea990a16cdc7aeca125bcedbc3766edd /gnu/packages/python-web.scm
parent9377be6a4816c92e13be34c8d3291895a96db757 (diff)
downloadguix-patches-5e25aeee162d88fd2a7c9254a3b3df1783e1b69b.tar
guix-patches-5e25aeee162d88fd2a7c9254a3b3df1783e1b69b.tar.gz
gnu: Add python-wadllib.
* gnu/packages/python-web.scm (python-wadllib): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 76d9642616..d6f068f607 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7394,3 +7394,21 @@ metadata from HTML markup. Currently, extruct supports:
@item Dublin Core Metadata (DC-HTML-2003)
@end itemize")
(license license:bsd-3)))
+
+(define-public python-wadllib
+ (package
+ (name "python-wadllib")
+ (version "1.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "wadllib" version))
+ (sha256
+ (base32 "1z65crvdsjxh9nahz1g6q021ijmv85ixmq88l96d61qh5imavndc"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-lazr-uri))
+ (home-page "https://launchpad.net/wadllib")
+ (synopsis "Web Application Description Language (WADL) navigation library")
+ (description "The @code{wadllib} Python library allows navigating HTTP
+resources using Web Application Description Language (WADL) files as guides.")
+ (license license:lgpl3)))