summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-19 14:31:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-19 15:05:42 +0200
commit5d3675371c96fbda209b064fe3bef4a18592c3b9 (patch)
treeca228a1e0f5638727aecaf28c7dcd7822061f294 /gnu/packages/python-web.scm
parentbf5929c5303511da338da894ce072c138fe8324f (diff)
downloadguix-patches-5d3675371c96fbda209b064fe3bef4a18592c3b9.tar
guix-patches-5d3675371c96fbda209b064fe3bef4a18592c3b9.tar.gz
gnu: python-s3transfer: Update to 0.2.0.
* gnu/packages/python-web.scm (python-s3transfer): Update to 0.2.0. [propagated-inputs]: Add python-urllib3.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6fe6d5ade8..cbcbe6c867 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2045,21 +2045,21 @@ Betamax.")
(define-public python-s3transfer
(package
(name "python-s3transfer")
- (version "0.1.13")
+ (version "0.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "s3transfer" version))
(sha256
(base32
- "1harvyn1s8v54n1w5h7c0lg4bgjh68aylhg28s8n174q53h1ip4h"))))
+ "08fhj73b1ai52hrs2q3nggshq3pswn1gq8ch3m009cb2v2vmqggj"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
- ;; 7 of the 'integration' tests require network access or login
- ;; credentials.
+ ;; Some of the 'integration' tests require network access or
+ ;; login credentials.
(invoke "nosetests" "--exclude=integration")
#t)))))
(native-inputs
@@ -2067,7 +2067,8 @@ Betamax.")
("python-mock" ,python-mock)
("python-nose" ,python-nose)))
(propagated-inputs
- `(("python-botocore" ,python-botocore)))
+ `(("python-botocore" ,python-botocore)
+ ("python-urllib3" ,python-urllib3)))
(synopsis "Amazon S3 Transfer Manager")
(description "S3transfer is a Python library for managing Amazon S3
transfers.")