summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:44:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:44:42 +0300
commit54b040a31c12f85a04bb514b271a13db2fd5c6d7 (patch)
treee7dec92ef4f1f6d206a93c98205b399781b61395 /gnu/packages/python-web.scm
parent047c1f24de61b599ec83b76bdb18a82fdb7dce4b (diff)
downloadguix-patches-54b040a31c12f85a04bb514b271a13db2fd5c6d7.tar
guix-patches-54b040a31c12f85a04bb514b271a13db2fd5c6d7.tar.gz
gnu: Add python-persistent.
* gnu/packages/python-web.scm (python-persistent): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1a33ebaf0e..57254df587 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4153,3 +4153,28 @@ Swagger.")
(description
"Manuel lets you mix and match traditional doctests with custom test syntax.")
(license license:asl2.0)))
+
+(define-public python-persistent
+ (package
+ (name "python-persistent")
+ (version "4.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "persistent" version))
+ (sha256
+ (base32
+ "0imm9ji03lhkpcfmhid7x5209ix8g2rlgki9ik1qxks4b8sm8gzq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cffi" ,python-cffi)
+ ("python-zope-interface" ,python-zope-interface)))
+ (native-inputs
+ `(("python-manuel" ,python-manuel)
+ ("python-zope-testrunner" ,python-zope-testrunner)))
+ (home-page "https://github.com/zopefoundation/persistent/")
+ (synopsis "Translucent persistent objects")
+ (description "This package contains a generic persistence implementation for
+Python. It forms the core protocol for making objects interact
+\"transparently\" with a database such as the ZODB.")
+ (license license:zpl2.1)))