summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-29 10:56:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-29 10:56:28 +0200
commit4b92dac20fbca636201a38916d65bf825d69cd7f (patch)
treea868f591b9e16c98e3dad1eed5026f9a759dc1fa /gnu/packages/python-web.scm
parentd37ba98409f2a5d7f5e7bdfe79d6b0466845474a (diff)
downloadguix-patches-4b92dac20fbca636201a38916d65bf825d69cd7f.tar
guix-patches-4b92dac20fbca636201a38916d65bf825d69cd7f.tar.gz
gnu: awscli: Add missing input.
Fixes <https://bugs.gnu.org/35980>. * gnu/packages/python-web.scm (awscli)[arguments]: Add build phase "fix-reference-to-groff". [inputs]: Add groff.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index aa0af3912f..042484c6a1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages django)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages libffi)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -1541,6 +1542,19 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(base32
"0sispclx263lybbk19zp1n9yhg8xxx4jddypzgi24vpjaqnsbwlc"))))
(build-system python-build-system)
+ (arguments
+ ;; FIXME: The 'pypi' release does not contain tests.
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-reference-to-groff
+ (lambda _
+ (substitute* "awscli/help.py"
+ (("if not self._exists_on_path\\('groff'\\):") "")
+ (("raise ExecutableNotFoundError\\('groff'\\)") "")
+ (("cmdline = \\['groff'")
+ (string-append "cmdline = ['" (which "groff") "'")))
+ #t)))))
(propagated-inputs
`(("python-colorama" ,python-colorama)
("python-botocore" ,python-botocore)
@@ -1548,9 +1562,8 @@ supports url redirection and retries, and also gzip and deflate decoding.")
("python-docutils" ,python-docutils)
("python-pyyaml" ,python-pyyaml)
("python-rsa" ,python-rsa)))
- (arguments
- ;; FIXME: The 'pypi' release does not contain tests.
- '(#:tests? #f))
+ (inputs
+ `(("groff" ,groff)))
(home-page "https://aws.amazon.com/cli/")
(synopsis "Command line client for AWS")
(description "AWS CLI provides a unified command line interface to the