summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-23 22:02:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-23 22:03:35 +0300
commit4907b615c98cd77f1ca1dc37f01145a0d9f4dd1c (patch)
tree1d4e1b981aba176a0f82ea669379b3544dc3f8d9 /gnu/packages/python-web.scm
parenta130544d60747d48098ef27dc0c6cf677ab65afa (diff)
downloadguix-patches-4907b615c98cd77f1ca1dc37f01145a0d9f4dd1c.tar
guix-patches-4907b615c98cd77f1ca1dc37f01145a0d9f4dd1c.tar.gz
gnu: python-html2text: Update to 2019.8.11.
* gnu/packages/python-web.scm (python-html2text): Update to 2019.8.11. [arguments]: Use a custom 'check phase. [home-page]: Update home-page.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0c93c03adf..e37ae94e18 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -306,16 +306,24 @@ other HTTP libraries.")
(define-public python-html2text
(package
(name "python-html2text")
- (version "2018.1.9")
+ (version "2019.8.11")
(source
(origin
(method url-fetch)
(uri (pypi-uri "html2text" version))
(sha256
(base32
- "1m6d7ciq30adc3d1n8g6r46072n7q8kdy039pqvnnmp763xi8xb2"))))
+ "0ppgjplg06kmv9sj0x8p7acczcq2mcfgk1jdjwm4w5w40b0vj5pm"))))
(build-system python-build-system)
- (home-page "https://pypi.org/project/html2text/")
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "test/"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/Alir3z4/html2text")
(synopsis "Convert HTML into plain text")
(description "html2text takes HTML and converts it into plain ASCII text
which is also valid markdown. html2text was originally written by Aaron