summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:56:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:56:09 +0300
commit4874cae680b725fbd292c3c626ad1c5182282a80 (patch)
treeed64912bba4d9ed62de815608edf902af104ae05 /gnu/packages/python-web.scm
parent7d55bc5e2a9fd3c2e72b82090854ce86fa6e44a1 (diff)
downloadguix-patches-4874cae680b725fbd292c3c626ad1c5182282a80.tar
guix-patches-4874cae680b725fbd292c3c626ad1c5182282a80.tar.gz
gnu: python-zope-security: Update to 5.1.1.
* gnu/packages/python-web.scm (python-zope-security): Update to 5.1.1. [arguments]: Don't skip tests. [native-inputs]: Add python-btrees, python-zope-component-bootstrap, python-zope-location-bootstrap. Replace python-zope-configuration with python-zope-configuration-bootstrap.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f23467bf8e..319638e3e2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1384,17 +1384,15 @@ Zope3, which are are special objects that have a structural location.")
(define-public python-zope-security
(package
(name "python-zope-security")
- (version "5.1.0")
+ (version "5.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "zope.security" version))
(sha256
(base32
- "1npfrgnm202v48wavpwn3450dsn7az12lfww95vbhxyjl11f14yb"))))
+ "11lfw67cigscfax9c5j63xcvz2qcj724zx5fcdqyc94am2glim0h"))))
(build-system python-build-system)
- (arguments
- '(#:tests? #f)) ; FIXME: Tests can't find zope.testrunner.
(propagated-inputs
`(("python-zope-component" ,python-zope-component)
("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
@@ -1403,9 +1401,12 @@ Zope3, which are are special objects that have a structural location.")
("python-zope-proxy" ,python-zope-proxy)
("python-zope-schema" ,python-zope-schema)))
(native-inputs
- `(("python-zope-configuration" ,python-zope-configuration)
- ("python-zope-testrunner" ,python-zope-testrunner)
- ("python-zope-testing" ,python-zope-testing)))
+ `(("python-btrees" ,python-btrees)
+ ("python-zope-component" ,python-zope-component-bootstrap)
+ ("python-zope-configuration" ,python-zope-configuration-bootstrap)
+ ("python-zope-location" ,python-zope-location-bootstrap)
+ ("python-zope-testing" ,python-zope-testing)
+ ("python-zope-testrunner" ,python-zope-testrunner)))
(home-page "https://pypi.org/project/zope.security/")
(synopsis "Zope security framework")
(description "Zope.security provides a generic mechanism to implement