summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:16:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:16:15 +0300
commit3f795cf8f7cf942f0d8756f8b6c06bc016c567cb (patch)
tree0df2cf4282ca8ea53b5a0c5f35ae2f7a907880f5 /gnu/packages/python-web.scm
parent256e8a82fa98f63a1416a283de86a32b074e7f7b (diff)
downloadguix-patches-3f795cf8f7cf942f0d8756f8b6c06bc016c567cb.tar
guix-patches-3f795cf8f7cf942f0d8756f8b6c06bc016c567cb.tar.gz
gnu: Add python-zope-copy.
* gnu/packages/python-web.scm (python-zope-copy): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4e3387f21e..338d73d1a9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1309,6 +1309,37 @@ Markup Language.")
(define-public python2-zope-configuration
(package-with-python2 python-zope-configuration))
+(define-public python-zope-copy
+ (package
+ (name "python-zope-copy")
+ (version "4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zope.copy" version))
+ (sha256
+ (base32
+ "06m75434krl57n6p73c2qj55k5i3fixg887j8ss01ih6zw4rvfs7"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "zope-testrunner" "--test-path=src" "\\[]"))))))
+ (propagated-inputs
+ `(("python-zope-interface" ,python-zope-interface)))
+ (native-inputs
+ `(("python-zope-component" ,python-zope-component-bootstrap)
+ ("python-zope-location" ,python-zope-location-bootstrap)
+ ("python-zope-testing" ,python-zope-testing)
+ ("python-zope-testrunner" ,python-zope-testrunner)))
+ (home-page "https://github.com/zopefoundation/zope.copy")
+ (synopsis "Pluggable object copying mechanism")
+ (description
+ "This package provides a pluggable mechanism for copying persistent objects.")
+ (license license:zpl2.1)))
+
(define-public python-zope-proxy
(package
(name "python-zope-proxy")