summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /gnu/packages/python-web.scm
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm38
1 files changed, 33 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a0770df17d..384caddd6b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019, 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
@@ -429,14 +429,14 @@ other HTTP libraries.")
(define-public httpie
(package
(name "httpie")
- (version "2.2.0")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpie" version))
(sha256
(base32
- "18058k0i3cc4ixvgzj882w693lf40283flvspbrvd876iq42ib1i"))))
+ "15ngl3yc186gkgqdx8iav9bpj8gxjpzz26y32z92jwyhj4cmfh6m"))))
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.
@@ -444,8 +444,9 @@ other HTTP libraries.")
(propagated-inputs
`(("python-colorama" ,python-colorama)
("python-pygments" ,python-pygments)
- ("python-requests" ,python-requests)))
- (home-page "https://httpie.org/")
+ ("python-requests" ,python-requests)
+ ("python-requests-toolbelt" ,python-requests-toolbelt-0.9.1)))
+ (home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
(description
"A command line HTTP client with an intuitive UI, JSON support,
@@ -5169,3 +5170,30 @@ Encoding for HTTP.")
"This module acts as a webbrowser solving Cloudflare's Javascript
challenges.")
(license license:expat)))
+
+(define-public python-imap-tools
+ (package
+ (name "python-imap-tools")
+ (version "0.29.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imap_tools" version))
+ (sha256
+ (base32
+ "0x122jwpc74wwyw2rsv2fvh6p12y31019ndfr9717jzjkj2d3lhb"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; tests require internet access
+ (home-page "https://github.com/ikvk/imap_tools")
+ (synopsis "Work with email and mailbox by IMAP")
+ (description
+ "This Python library provides tools to deal with email and mailboxes
+over IMAP:
+
+@itemize
+@item Parsed email message attributes
+@item Query builder for searching emails
+@item Work with emails in folders (copy, delete, flag, move, seen)
+@item Work with mailbox folders (list, set, get, create, exists, rename, delete, status)
+@end itemize")
+ (license license:asl2.0)))