summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:18:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:18:20 +0300
commit2f938b634e0265fc6d3348cdcba9c788303c0136 (patch)
treeb3f4a858b8c9db0626fee873d3d76cab1d577850 /gnu/packages/python-web.scm
parent7dc36cdc8f77ad3a542823278f9d03e70714b4c7 (diff)
downloadguix-patches-2f938b634e0265fc6d3348cdcba9c788303c0136.tar
guix-patches-2f938b634e0265fc6d3348cdcba9c788303c0136.tar.gz
gnu: Add python-zope-testrunner-bootstrap.
* gnu/packages/python-web.scm (python-zope-testrunner-bootstrap): New hidden package.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ba8c1fe3c7..a9f362e0bc 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1189,6 +1189,15 @@ forms, HTTP servers, regular expressions, and more.")
tests.")
(license license:zpl2.1)))
+(define-public python-zope-testrunner-bootstrap
+ (package
+ (inherit python-zope-testrunner)
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-zope-exceptions" ,python-zope-exceptions-bootstrap)))
+ (properties `((hidden? . #t)))))
+
(define-public python2-zope-testrunner
(package-with-python2 python-zope-testrunner))