summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:11:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:11:11 +0300
commit2ed6491f9c07c06537ed43db12e23c829da96622 (patch)
tree03dbfad078b0d7ff085d166ed835a3ca337b8f74 /gnu/packages/python-web.scm
parent404d4915db90ea783e46ce8297cee04e3603ac19 (diff)
downloadguix-patches-2ed6491f9c07c06537ed43db12e23c829da96622.tar
guix-patches-2ed6491f9c07c06537ed43db12e23c829da96622.tar.gz
gnu: Add python-zope-deferredimport.
* gnu/packages/python-web.scm (python-zope-deferredimport): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5cfc6b97e9..77a6e95737 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1492,6 +1492,32 @@ facilities for defining, registering and looking up components.")
(define-public python2-zope-component
(package-with-python2 python-zope-component))
+(define-public python-zope-deferredimport
+ (package
+ (name "python-zope-deferredimport")
+ (version "4.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zope.deferredimport" version))
+ (sha256
+ (base32
+ "1q89v54dwniiqypjbwywwdfjdr4kdkqlyqsgrpplgvsygdg39cjp"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-zope-proxy" ,python-zope-proxy)))
+ (native-inputs
+ `(("python-zope-testrunner" ,python-zope-testrunner)))
+ (home-page "https://github.com/zopefoundation/zope.deferredimport")
+ (synopsis "Defer imports until used by code")
+ (description
+ "Often, especially for package modules, you want to import names for
+convenience, but not actually perform the imports until necessary. The
+@code{zope.deferredimport} package provided facilities for defining names in
+modules that will be imported from somewhere else when used. You can also cause
+deprecation warnings to be issued when a variable is used.")
+ (license license:zpl2.1)))
+
(define-public python-ndg-httpsclient
(package
(name "python-ndg-httpsclient")