summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <guix-patches@gnu.org>2022-08-14 18:35:58 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-15 09:45:31 +0200
commit18ae404690e8b96c5a97886b506e75c4c1b21b6d (patch)
tree0ea75bd35c8325af932da4880c8c8e88a574ae01 /gnu/packages/python-web.scm
parent8fce5f0f0f644981e262ed0f848ede8fa0c14170 (diff)
downloadguix-patches-18ae404690e8b96c5a97886b506e75c4c1b21b6d.tar
guix-patches-18ae404690e8b96c5a97886b506e75c4c1b21b6d.tar.gz
gnu: Add python-whatthepatch.
* gnu/packages/python-web.scm (python-whatthepatch): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 896e60aba2..59a3ee516d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7761,3 +7762,20 @@ admin section of stores using an ActiveResource-like interface similar the
ruby Shopify API gem. The library makes HTTP requests to Shopify in order to
list, create, update, or delete resources (e.g. Order, Product, Collection).")
(license license:expat)))
+
+(define-public python-whatthepatch
+ (package
+ (name "python-whatthepatch")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "whatthepatch" version))
+ (sha256
+ (base32
+ "17zspm5sxhvggkdhwq4s0fzf4mkc825xshn734g2j2iy2xcylh65"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/cscorley/whatthepatch")
+ (synopsis "Patch parsing and application")
+ (description
+ "This package provides a library to parse and apply patches.")
+ (license license:expat)))