summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 03:55:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:33 +0100
commit0a044f75b54d92417debf600fe7c4c4f86af344d (patch)
tree8e227cdb67c427fbd77a50779c6fcb813b7d3505 /gnu/packages/python-web.scm
parent8f29817ed523dd4e5dbd459ecb94dbd1cab6a4fc (diff)
downloadguix-patches-0a044f75b54d92417debf600fe7c4c4f86af344d.tar
guix-patches-0a044f75b54d92417debf600fe7c4c4f86af344d.tar.gz
gnu: python-flask-restful: Update to 0.3.8.
* gnu/packages/patches/python-flask-restful-werkzeug-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-web.scm (python-flask-restful): Update to 0.3.8. [source](patches): New field. [native-inputs]: Remove PYTHON-SPHINX.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6d4204bad0..ae01f83611 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2173,14 +2173,15 @@ pretty printer and a tree visitor.")
(define-public python-flask-restful
(package
(name "python-flask-restful")
- (version "0.3.7")
+ (version "0.3.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-RESTful" version))
+ (patches (search-patches "python-flask-restful-werkzeug-compat.patch"))
(sha256
(base32
- "1a9cbwkr6krryyzq4sd3f415nkkc6dyfls5i3pgyibs94g0hw97q"))))
+ "05b9lzx5yc3wgml2bcq50lq35h66m8zpj6dc9advcb5z3acsbaay"))))
(build-system python-build-system)
(propagated-inputs
`(("python-aniso8601" ,python-aniso8601)
@@ -2191,8 +2192,7 @@ pretty printer and a tree visitor.")
`(;; Optional dependency of Flask. Tests need it.
("python-blinker" ,python-blinker)
("python-mock" ,python-mock) ; For tests
- ("python-nose" ,python-nose) ; For tests
- ("python-sphinx" ,python-sphinx)))
+ ("python-nose" ,python-nose))) ;for tests
(home-page
"https://www.github.com/flask-restful/flask-restful/")
(synopsis