summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2021-03-13 20:37:16 -0600
committerEric Bavier <bavier@member.fsf.org>2021-03-14 13:24:21 -0500
commit078f3288e29ddab9a10187b1d0697c57448eac7b (patch)
tree432f6a6ade593f5bc15025fbd8c2ab8182af99de /gnu/packages/python-web.scm
parent7164d2105af9d0ebd53f5f4ecbaf1ecd02825e79 (diff)
downloadguix-patches-078f3288e29ddab9a10187b1d0697c57448eac7b.tar
guix-patches-078f3288e29ddab9a10187b1d0697c57448eac7b.tar.gz
gnu: Add python-socketio.
* gnu/packages/python-web.scm (python-socketio): New variable.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 586e778bff..9828d5e61c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5826,6 +5826,32 @@ that's written to go fast. It allows the usage of the
your code non-blocking and speedy.")
(license license:expat)))
+(define-public python-socketio
+ (package
+ (name "python-socketio")
+ (version "5.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-socketio" version))
+ (sha256
+ (base32
+ "14vhpxdn54lz54mhcqlgcks0ssbws9gd1y7ii16a2g3gpfdc531k"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aiohttp" ,python-aiohttp)
+ ("python-bidict" ,python-bidict)
+ ("python-engineio" ,python-engineio)
+ ("python-requests" ,python-requests)
+ ("python-websocket-client" ,python-websocket-client)
+ ("python-websockets" ,python-websockets)))
+ (arguments '(#:tests? #f)) ; Tests not included in release tarball.
+ (home-page "https://github.com/miguelgrinberg/python-socketio/")
+ (synopsis "Python Socket.IO server")
+ (description
+ "Python implementation of the Socket.IO realtime client and server.")
+ (license license:expat)))
+
(define-public python-socks
(package
(name "python-socks")