summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-04-27 19:36:35 +1000
committerAndreas Enge <andreas@enge.fr>2019-05-03 13:58:22 +0200
commit02eb70bd21cc1cd493517450e9d0e626fe478704 (patch)
tree7851c51f8ddccdbcaca4c0f9ef0c5eae9c9c7537 /gnu/packages/python-web.scm
parentc2dd07aba5b61cc76f92aa84d99e251331612855 (diff)
downloadguix-patches-02eb70bd21cc1cd493517450e9d0e626fe478704.tar
guix-patches-02eb70bd21cc1cd493517450e9d0e626fe478704.tar.gz
gnu: Add python-css-parser, python2-css-parser.
* gnu/packages/python-web.scm (python-css-parser, python2-css-parser): New variables. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 50d7097d38..37da0fd669 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -637,6 +637,28 @@ options.")
(define-public python2-cssutils
(package-with-python2 python-cssutils))
+(define-public python-css-parser
+ (package
+ (inherit python-cssutils)
+ (name "python-css-parser")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "css-parser" version ".tar.gz"))
+ (sha256
+ (base32
+ "0i4xfykiffxzr4f6y0m2ggqvx1rzam6pw6krlr5k6ldf29akbay7"))))
+ (home-page "https://github.com/ebook-utils/css-parser")
+ (synopsis "Fork of cssutils modified for parsing ebooks")
+ (description
+ "Css-parser is a fork of cssutils 1.0.2, updated and modified for parsing
+ebooks, due to cssutils not receiving updates as of 1.0.2.")
+ (license license:lgpl3+)))
+
+(define-public python2-css-parser
+ (package-with-python2 python-css-parser))
+
(define-public python-cssselect
(package
(name "python-cssselect")