summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-07-13 14:59:34 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-07-13 17:11:20 +0530
commitf79fce798122d8b6c3b2f8d45bd4533ed281eae8 (patch)
tree627907886046878329d48bd04db1f24f2f78f03f /gnu/packages/python-science.scm
parent956b6b078edbb96c207747e89ae485d8a4268c6b (diff)
downloadguix-patches-f79fce798122d8b6c3b2f8d45bd4533ed281eae8.tar
guix-patches-f79fce798122d8b6c3b2f8d45bd4533ed281eae8.tar.gz
gnu: Add python-pandas-flavor.
* gnu/packages/python-science.scm (python-pandas-flavor): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index d2c4caac3a..1292781f2b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -733,3 +734,30 @@ dependencies.")
license:silofl1.1
license:cc0
license:public-domain))))
+
+(define-public python-pandas-flavor
+ (package
+ (name "python-pandas-flavor")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandas_flavor" version))
+ (sha256
+ (base32
+ "12g4av8gpl6l83yza3h97j3f2jblqv69frlidrvdq8ny2rc6awbq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pandas" ,python-pandas)
+ ("python-xarray" ,python-xarray)))
+ (home-page "https://github.com/Zsailer/pandas_flavor")
+ (synopsis "Write your own flavor of Pandas")
+ (description "Pandas 0.23 added a simple API for registering accessors
+with Pandas objects. Pandas-flavor extends Pandas' extension API by
+
+@itemize
+@item adding support for registering methods as well
+@item making each of these functions backwards compatible with older versions
+of Pandas
+@end itemize")
+ (license license:expat)))