summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-15 22:49:43 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-16 09:42:36 +0200
commitd2b014aab3bb902667a028951f9af860377a809f (patch)
tree0890e69d75ba17e5dfb1bb9b7ea7f5710e3d77d9 /gnu/packages/python-science.scm
parentd474052b9515c5ea048c9e29a1c636843eac41cf (diff)
downloadguix-patches-d2b014aab3bb902667a028951f9af860377a809f.tar
guix-patches-d2b014aab3bb902667a028951f9af860377a809f.tar.gz
gnu: Add python-sgp4.
* gnu/packages/python-science.scm (python-sgp4): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7675152d79..101c8fb640 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -265,6 +265,26 @@ logic, also known as grey logic.")
"Scikit-image is a collection of algorithms for image processing.")
(license license:bsd-3)))
+(define-public python-sgp4
+ (package
+ (name "python-sgp4")
+ (version "2.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sgp4" version))
+ (sha256
+ (base32 "0dncp9i5b6afkg7f8mj9j0qzsp008b8v73yc0qkmizhpns7mvwvx"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (home-page "https://github.com/brandon-rhodes/python-sgp4")
+ (synopsis "Track earth satellite TLE orbits using SGP4")
+ (description
+ "This package provides a Python implementation of the most recent version
+of the SGP4 satellite tracking algorithm.")
+ (license license:expat)))
+
(define-public python-pandas
(package
(name "python-pandas")