summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-14 17:17:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-14 23:13:56 +0200
commitb63cae13c11dee345632d65ddc57e5e6d4e5cf10 (patch)
tree3de033da704ff1e648fbc469ddc45cc011398dea /gnu/packages/python-science.scm
parent27a26663f60c7ddb7c1041b77c6e2e2b38e840bf (diff)
downloadguix-patches-b63cae13c11dee345632d65ddc57e5e6d4e5cf10.tar
guix-patches-b63cae13c11dee345632d65ddc57e5e6d4e5cf10.tar.gz
gnu: Add python-ruffus.
* gnu/packages/python-science.scm (python-ruffus): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 39f52f1d64..10fb2403e6 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -583,6 +583,37 @@ by numpy using the highly efficient @code{msgpack} format. Serialization of
Python's native complex data types is also supported.")
(license license:bsd-3)))
+(define-public python-ruffus
+ (package
+ (name "python-ruffus")
+ (version "2.8.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ruffus" version))
+ (sha256
+ (base32
+ "1ai673k1s94s8b6pyxai8mk17p6zvvyi87rl236fs6ls8mpdklvc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (with-directory-excursion "ruffus/test"
+ (invoke "bash" "run_all_unit_tests3.cmd"))))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "http://www.ruffus.org.uk")
+ (synopsis "Light-weight computational pipeline management")
+ (description
+ "Ruffus is designed to allow scientific and other analyses to be
+automated with the minimum of fuss and the least effort.")
+ (license license:expat)))
+
(define-public python-statannot
(package
(name "python-statannot")