summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-25 12:40:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-25 14:01:32 +0300
commita0400dc9a5b5614d0d732bc07aeb7e83746c1db1 (patch)
treecbcc80e0d40b4dc462185dd8d39e8ce556bcf87e /gnu/packages/python-science.scm
parentab961fe54232baf093c91cb7bc8433eebbadf461 (diff)
downloadguix-patches-a0400dc9a5b5614d0d732bc07aeb7e83746c1db1.tar
guix-patches-a0400dc9a5b5614d0d732bc07aeb7e83746c1db1.tar.gz
gnu: python-pandas: Honor #:tests? flag.
* gnu/packages/python-science.scm (python-pandas)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b68a2838fc..203e146dbc 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -359,26 +359,27 @@ of the SGP4 satellite tracking algorithm.")
;; xsel needs to write a log file.
(setenv "HOME" "/tmp")))
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
(let ((build-directory
(string-append
(getcwd) "/build/"
(first (scandir "build"
(cut string-prefix? "lib." <>))))))
(with-directory-excursion build-directory
- (invoke "pytest" "-vv" "pandas" "--skip-slow"
- "--skip-network"
- "-k"
- ;; These tets access the internet:
- ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[lxml]
- ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[etree]
- ;; TODO: the excel tests fail for unknown reasons
- (string-append "not test_wrong_url"
- " and not test_excelwriter_fspath"
- " and not test_ExcelWriter_dispatch"
- ;; TODO: Missing input
- " and not TestS3"
- " and not s3")))))))))
+ (when tests?
+ (invoke "pytest" "-vv" "pandas" "--skip-slow"
+ "--skip-network"
+ "-k"
+ ;; These tets access the internet:
+ ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[lxml]
+ ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[etree]
+ ;; TODO: the excel tests fail for unknown reasons
+ (string-append "not test_wrong_url"
+ " and not test_excelwriter_fspath"
+ " and not test_ExcelWriter_dispatch"
+ ;; TODO: Missing input
+ " and not TestS3"
+ " and not s3"))))))))))
(propagated-inputs
`(("python-jinja2" ,python-jinja2)
("python-numpy" ,python-numpy)