summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-13 19:23:41 +0100
committerMarius Bakke <marius@gnu.org>2021-12-13 23:28:58 +0100
commit95447b293d52189056224076c25299fca1338018 (patch)
treeed8fd6d8e23956ea0ea2094f98f786b10b2c8cc9 /gnu/packages/python-science.scm
parent48a6f1d351a0f119ca25ae9b66f535dd2300ac7d (diff)
downloadguix-patches-95447b293d52189056224076c25299fca1338018.tar
guix-patches-95447b293d52189056224076c25299fca1338018.tar.gz
gnu: python-distributed: Update to 2021.11.2.
* gnu/packages/python-science.scm (python-distributed): Update to 2021.11.2. [source](snippet): New field. [arguments]: Add versioneer phase. [native-inputs]: Add PYTHON-VERSIONEER.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index d23c56daa6..b102549463 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -890,7 +890,7 @@ and more
(define-public python-distributed
(package
(name "python-distributed")
- (version "2021.09.1")
+ (version "2021.11.2")
(source
(origin
;; The test files are not included in the archive on pypi
@@ -901,11 +901,16 @@ and more
(file-name (git-file-name name version))
(sha256
(base32
- "05djzza3f72nw1i1c9qyamgaf93pbf6jxx0migpp1wvvfl0v2j9z"))))
+ "1p20cbyabzl7rs8y3ydzszsskh4kw088m252ghgairhs0p2f95hl"))
+ ;; Delete bundled copy of python-versioneer.
+ (snippet '(delete-file "versioneer.py"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'versioneer
+ (lambda _
+ (invoke "versioneer" "install")))
(add-after 'unpack 'fix-references
(lambda* (#:key outputs #:allow-other-keys)
(substitute* '("distributed/comm/tests/test_ucx_config.py"
@@ -954,7 +959,7 @@ and more
python-tornado-6
python-zict))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-versioneer))
(home-page "https://distributed.dask.org")
(synopsis "Distributed scheduler for Dask")
(description "Dask.distributed is a lightweight library for distributed