summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-12 13:34:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-12 13:35:02 +0100
commit4d0fdde344509c4fa37bc7e5dd1e391fd50a8b2e (patch)
treebab0e41bd73794fdb6fa315f474d9a35451544ff /gnu/packages/python-science.scm
parent5fa4814b4f12b82a7a7747bfacfb45b0348eae1e (diff)
downloadguix-patches-4d0fdde344509c4fa37bc7e5dd1e391fd50a8b2e.tar
guix-patches-4d0fdde344509c4fa37bc7e5dd1e391fd50a8b2e.tar.gz
gnu: Add python-statannot.
* gnu/packages/python-science.scm (python-statannot): New variable.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index a1e2b57669..5221f41af7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -531,3 +531,29 @@ serialization and deserialization of numerical and array data types provided
by numpy using the highly efficient @code{msgpack} format. Serialization of
Python's native complex data types is also supported.")
(license license:bsd-3)))
+
+(define-public python-statannot
+ (package
+ (name "python-statannot")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "statannot" version))
+ (sha256
+ (base32
+ "1f8c2sylzr7lpjbyqxsqlp9xi8rj3d8c9hfh98x4jbb83zxc4026"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-seaborn" ,python-seaborn)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-pandas" ,python-pandas)
+ ("python-scipy" ,python-scipy)))
+ (home-page
+ "https://github.com/webermarcolivier/statannot")
+ (synopsis "Add annotations to existing plots generated by seaborn")
+ (description
+ "This is a Python package to compute statistical test and add statistical
+annotations on an existing boxplots and barplots generated by seaborn.")
+ (license license:expat)))