summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/python-science.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7572a8102b..0677843216 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -160,11 +160,12 @@ atlas_libs = openblas
;; within the source directory.
(delete 'check)
(add-after 'install 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (with-directory-excursion "/tmp"
- (invoke "python" "-c"
- "import scipy; scipy.test(verbose=2)")))))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (with-directory-excursion "/tmp"
+ (invoke "python" "-c"
+ "import scipy; scipy.test(verbose=2)"))))))))
(home-page "https://www.scipy.org/")
(synopsis "The Scipy library provides efficient numerical routines")
(description "The SciPy library is one of the core packages that make up
@@ -833,7 +834,7 @@ of Pandas
(define-public python-pingouin
(package
(name "python-pingouin")
- (version "0.3.12")
+ (version "0.5.0")
(source
;; The PyPI tarball does not contain the tests.
(origin
@@ -844,7 +845,7 @@ of Pandas
(file-name (git-file-name name version))
(sha256
(base32
- "1ap29x54kdr19vi8qxj9g6cz2r1q4f0z7dcf6g77zwav7hf7r61a"))))
+ "01aaq023q4bymffrc2wm56af87da32wcvy5d5156i4g7qgvh346r"))))
(build-system python-build-system)
(arguments
`(#:phases