summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-03-09 11:15:54 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-13 13:55:15 +0100
commit36062f16b6bce9e5178ba4614d1c8e763a96eb64 (patch)
treefd5ebf05b6815ea4819f109e5718289f59213d87 /gnu/packages/python-science.scm
parent211c933077a6c61eb3a7a67df60cb01b1b5a2c3f (diff)
downloadguix-patches-36062f16b6bce9e5178ba4614d1c8e763a96eb64.tar
guix-patches-36062f16b6bce9e5178ba4614d1c8e763a96eb64.tar.gz
gnu: python-scikit-image: Update to 0.18.1.
* gnu/packages/python-science.scm (python-scikit-image): Update to 0.18.1. [propagated-inputs]: Remove python-six. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 391d37dcce..409745819b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
@@ -240,18 +240,18 @@ logic, also known as grey logic.")
(define-public python-scikit-image
(package
(name "python-scikit-image")
- (version "0.17.2")
+ (version "0.18.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "scikit-image" version))
(sha256
- (base32 "1cyqqbcbrg3prc36wis0sm3q5rjhd7h9bp33jwfyixzhi02lr5dx"))))
+ (base32 "0wgisa03smhrphcjnhq7waa5vyyd32b67hblapjbqrqqj751idpv"))))
(build-system python-build-system)
(arguments
;; TODO: Some tests require running X11 server. Disable them?
'(#:tests? #f))
- ;; See DEPENDS.txt for the list of build and run time requiremnts
+ ;; See requirements/ for the list of build and run time requirements.
(propagated-inputs
`(("python-cloudpickle" ,python-cloudpickle)
("python-dask" ,python-dask)
@@ -262,7 +262,6 @@ logic, also known as grey logic.")
("python-pillow" ,python-pillow)
("python-pywavelets" ,python-pywavelets)
("python-scipy" ,python-scipy)
- ("python-six" ,python-six)
("python-tifffile" ,python-tifffile)))
(native-inputs
`(("python-cython" ,python-cython)))