summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-22 20:25:54 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-06 15:23:06 +0200
commit34f49d15e649cd42338524352f0c971374bc2262 (patch)
treea711d313a34947308c62d898c0ed96e381add7cc /gnu/packages/python-science.scm
parentb7d2644cd04f0f14e22d4c7232a508e6e7e2299e (diff)
downloadguix-patches-34f49d15e649cd42338524352f0c971374bc2262.tar
guix-patches-34f49d15e649cd42338524352f0c971374bc2262.tar.gz
gnu: python-vedo: Honor #:tests? flag.
* gnu/packages/python-science.scm (python-vedo)[arguments]: Adjust custom 'check' phase to honor the #:tests? flag. Also remove its trailing boolean. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 3ad2cc4d87..bbdd4b86eb 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -876,15 +876,15 @@ readable.")
(add-after 'build 'mpi-setup
,%openmpi-setup)
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (setenv "HOME" (getcwd))
- (add-installed-pythonpath inputs outputs)
- (with-directory-excursion "tests"
- (for-each (lambda (dir)
- (with-directory-excursion dir
- (invoke "./run_all.sh")))
- '("common" "dolfin")))
- #t)))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (add-installed-pythonpath inputs outputs)
+ (with-directory-excursion "tests"
+ (for-each (lambda (dir)
+ (with-directory-excursion dir
+ (invoke "./run_all.sh")))
+ '("common" "dolfin")))))))))
(inputs ; for the check phase
`(("dolfin" ,fenics)
("pkgconfig" ,python-pkgconfig)