summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-12-16 09:48:02 +0100
committerLars-Dominik Braun <lars@6xq.net>2021-12-16 09:48:02 +0100
commit08218fd7a4e941c83d069d7f4fd89f0a9dee60e2 (patch)
tree643c95b7ad46996afa717133c89136e119a99938 /gnu/packages/python-science.scm
parent974264af3782be047b4fb1765fbb67964d67a643 (diff)
downloadguix-patches-08218fd7a4e941c83d069d7f4fd89f0a9dee60e2.tar
guix-patches-08218fd7a4e941c83d069d7f4fd89f0a9dee60e2.tar.gz
gnu: python-pyflow: Rename to python2-pyflow.
The package was never compatible with Python 3. Not adding a deprecated package variant, because going from Python 3 to Python 2 is a breaking change and it’s unlikely anyone ever used the package anyway (it was likely broken). * gnu/packages/python-science.scm (python-pyflow): Move… (python2-pyflow): …here. [arguments]: Use Python 2.
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index b102549463..393e59896d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -514,9 +514,9 @@ doing practical, real world data analysis in Python.")
python2-pytest
python2-pytest-mock)))))
-(define-public python-pyflow
+(define-public python2-pyflow
(package
- (name "python-pyflow")
+ (name "python2-pyflow")
(version "1.1.20")
(source (origin
(method url-fetch)
@@ -528,7 +528,10 @@ doing practical, real world data analysis in Python.")
"1bvfvviw58cndyn862qnv9nj3d9cd3a0dm4vc4sd9vwq8a6z1riv"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ; There is no test suite.
+ `(#:tests? #f ; There is no test suite.
+ ;; There is no official Python 3-compatible version and upstream is
+ ;; dead. See https://github.com/Illumina/pyflow/issues/20.
+ #:python ,python-2))
(home-page "https://illumina.github.io/pyflow/")
(synopsis "Tool to manage tasks in a task dependency graph")
(description "This package is a Python module to manage tasks in the