summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2018-06-25 21:32:06 -0700
committerMarius Bakke <mbakke@fastmail.com>2018-06-26 23:52:36 +0200
commite64088f0b521145286bfe3f028699e418baf4832 (patch)
tree4c45baa14e3061bee8320423871a6c619a80b8a8 /gnu/packages/python-crypto.scm
parent7abe38262aaeec78e70b6fee50dea9f0b5d557e8 (diff)
downloadguix-patches-e64088f0b521145286bfe3f028699e418baf4832.tar
guix-patches-e64088f0b521145286bfe3f028699e418baf4832.tar.gz
gnu: Add python-pyblake2.
* gnu/packages/python-crypto.scm (python-pyblake2): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index e29eaea801..6162fc835f 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -173,6 +174,32 @@ John the Ripper).")
(define-public python2-py-bcrypt
(package-with-python2 python-py-bcrypt))
+(define-public python-pyblake2
+ (package
+ (name "python-pyblake2")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyblake2" version))
+ (sha256
+ (base32
+ "0gz9hgznv5zw4qjq43xa56y0yikimx30gffvibxzm0nv5sq7xk2w"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/dchest/pyblake2")
+ (synopsis "BLAKE2 hash function for Python")
+ (description "BLAKE2 is a cryptographic hash function, which offers
+stronger security while being as fast as MD5 or SHA-1, and comes in two
+flavors: @code{BLAKE2b}, optimized for 64-bit platforms and produces digests
+of any size between 1 and 64 bytes, and @code{BLAKE2s}, optimized for 8- to
+32-bit platforms and produces digests of any size between 1 and 32 bytes.
+
+This package provides a Python interface for BLAKE2.")
+ ;; The COPYING file declares it as public domain, with the option to
+ ;; alternatively use and redistribute it under a variety of permissive
+ ;; licenses. cc0 is explicitly mentioned in setup.py and pyblake2module.c.
+ (license (list license:public-domain license:cc0))))
+
(define-public python-paramiko
(package
(name "python-paramiko")