summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-09-17 17:55:34 +0000
committerLudovic Courtès <ludo@gnu.org>2021-09-30 23:44:49 +0200
commite29c3e1856b8d05cf98d652207df981ae7197d3a (patch)
tree7b5d790521b788709baa14233deaf6461c075a02 /gnu/packages/python-crypto.scm
parent6d6b3a0c3ceeead480cfab398dd7515252e5a22a (diff)
downloadguix-patches-e29c3e1856b8d05cf98d652207df981ae7197d3a.tar
guix-patches-e29c3e1856b8d05cf98d652207df981ae7197d3a.tar.gz
gnu: Remove python-py-bcrypt.
* gnu/packages/python-crypto.scm (python-py-bcrypt, python2-py-bcrypt): Remove variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index bfc97e53b3..1cddc56f1b 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -171,38 +171,6 @@ useful for a wide range of tasks, from verifying a hash found in /etc/shadow,
to providing full-strength password hashing for multi-user application.")
(license license:bsd-3)))
-(define-public python-py-bcrypt
- (package
- (name "python-py-bcrypt")
- (version "0.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "py-bcrypt" version))
- (sha256
- (base32
- "0y6smdggwi5s72v6p1nn53dg6w05hna3d264cq6kas0lap73p8az"))))
- (build-system python-build-system)
- (home-page "https://code.google.com/p/py-bcrypt")
- (synopsis
- "Bcrypt password hashing and key derivation")
- (description
- "A python wrapper of OpenBSD's Blowfish password hashing code. This
-system hashes passwords using a version of Bruce Schneier's Blowfish block
-cipher with modifications designed to raise the cost of off-line password
-cracking and frustrate fast hardware implementation. The computation cost of
-the algorithm is parametrised, so it can be increased as computers get faster.
-The intent is to make a compromise of a password database less likely to
-result in an attacker gaining knowledge of the plaintext passwords (e.g. using
-John the Ripper).")
- ;; "sha2.c" is under BSD-3;
- ;; "blowfish.c" and "bcrypt.c" are under BSD-4;
- ;; the rest is under ISC.
- (license (list license:isc license:bsd-3 license:bsd-4))))
-
-(define-public python2-py-bcrypt
- (package-with-python2 python-py-bcrypt))
-
(define-public python-pyblake2
(package
(name "python-pyblake2")