summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-23 23:49:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:52 -0500
commitcbb9fab20f1c5b525d7587b65d7d6163bfe1a9a0 (patch)
treef560604e551855b263c48d2e44c79a3b6822e572 /gnu/packages/python-crypto.scm
parent824f32a1a2ee266ad270de496484ce3d9f4c4b71 (diff)
downloadguix-patches-cbb9fab20f1c5b525d7587b65d7d6163bfe1a9a0.tar
guix-patches-cbb9fab20f1c5b525d7587b65d7d6163bfe1a9a0.tar.gz
gnu: python-pynacl: Do not set PYTHONPATH.
* gnu/packages/python-crypto.scm (python-pynacl): Delete trailing #t. [arguments]: Remove the '#:modules' argument. [phases]: Use %standard-phases. Do not set PYTHONPATH.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm22
1 files changed, 6 insertions, 16 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 1f491cc972..39b194b25e 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -789,31 +790,20 @@ PKCS#8, PKCS#12, PKCS#5, X.509 and TSP.")
(substitute* "setup.py"
(("\"wheel\"") ""))
;; Remove bundled libsodium.
- (delete-file-recursively "src/libsodium")
- #t))
+ (delete-file-recursively "src/libsodium")))
(sha256
(base32
"01b56hxrbif3hx8l6rwz5kljrgvlbj7shmmd2rjh0hn7974a5sal"))))
(build-system python-build-system)
(arguments
- `(#:modules (,@%python-build-system-modules
- (guix build utils)
- (ice-9 ftw)
- (srfi srfi-26))
- #:phases
- (modify-phases (@ (guix build python-build-system) %standard-phases)
+ `(#:phases
+ (modify-phases %standard-phases
(add-before 'build 'use-system-sodium
(lambda _
- (setenv "SODIUM_INSTALL" "system")
- #t))
+ (setenv "SODIUM_INSTALL" "system")))
(replace 'check
(lambda _
- (let ((build-directory
- (car (scandir "build" (cut string-prefix? "lib" <>)))))
- (setenv "PYTHONPATH"
- (string-append "./build/" build-directory ":"
- (getenv "PYTHONPATH")))
- (invoke "pytest" "-vv")))))))
+ (invoke "pytest" "-vv"))))))
(native-inputs
`(("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)))