summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 20:47:00 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:17 +0100
commitc006f68fdb356835c46ed236769581925f753031 (patch)
tree07a066cad2e7a7b857f6bd21590fbf615a09ee5e /gnu/packages/python-crypto.scm
parent4ccb22802c6a7ba122dd95d01e569c613c313ddf (diff)
downloadguix-patches-c006f68fdb356835c46ed236769581925f753031.tar
guix-patches-c006f68fdb356835c46ed236769581925f753031.tar.gz
gnu: python-base58: Update to 2.1.1.
* gnu/packages/python-crypto.scm (python-base58)[arguments]: Override check phase. [native-inputs]: Add PYTHON-PYTEST and PYTHON-PYTEST-BENCHMARK.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 2072e4e164..89c0cf0e0c 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -96,17 +96,22 @@ Python. It does not bind to libotr.")
(define-public python-base58
(package
(name "python-base58")
- (version "2.0.1")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "base58" version))
(sha256
(base32
- "0yfaqp76kbdb62hikr5n4jkkfjfmii89grwfy6sw3fmsv5hrap1n"))))
+ "1317ly0db7nnjg5k58f6nqa0svfcvn446xd5bpiyi0bfbczwpl65"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv")))))))
(native-inputs
- (list python-pyhamcrest))
+ (list python-pyhamcrest python-pytest python-pytest-benchmark))
(home-page "https://github.com/keis/base58")
(synopsis "Base58 and Base58Check implementation")
(description "Base58 and Base58Check implementation compatible