summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-30 00:40:10 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-30 22:14:11 +0100
commitaadd107d5a3c0e3ead56a699407314a4b75244ee (patch)
tree5133bee32dad882fd162cd4ee8bf2292e55c66a6 /gnu/packages/python-crypto.scm
parent4e5e3bb8b9432062ba0539395ec5e8cb2d7ec23f (diff)
downloadguix-patches-aadd107d5a3c0e3ead56a699407314a4b75244ee.tar
guix-patches-aadd107d5a3c0e3ead56a699407314a4b75244ee.tar.gz
gnu: python-passlib: Update to 1.7.2.
* gnu/packages/python-crypto.scm (python-passlib): Update to 1.7.2.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 2b1543bbc0..af51ae04b6 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -109,14 +109,13 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
(define-public python-passlib
(package
(name "python-passlib")
- (version "1.7.1")
+ (version "1.7.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "passlib" version))
(sha256
- (base32
- "1q2khqpj9rlcgdmkypjdq1kswvhjf72bq0zk2cv669cc2dj8z51x"))))
+ (base32 "1a5ngap7kq0b4azq8nlfg6xg5bcl1i0v1sbynhmbr631jgpnqrld"))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))
@@ -129,8 +128,7 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
;; some tests require access to "$HOME/.cython"
(lambda* _ (setenv "PYTHON_EGG_CACHE" "/tmp") #t)))))
(home-page "https://bitbucket.org/ecollins/passlib")
- (synopsis
- "Comprehensive password hashing framework")
+ (synopsis "Comprehensive password hashing framework")
(description
"Passlib is a password hashing library for Python 2 & 3, which provides
cross-platform implementations of over 30 password hashing algorithms, as well