summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-05 22:56:40 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-06 00:18:30 +0000
commita8448da0f4a090818104e64dd79f90b0e50d5e77 (patch)
tree494c58b4724f12cd9de0db9b0a7096de2b922c0f /gnu/packages/python-crypto.scm
parent4f4b749e75b38b8c08b4f67ef51c2c8740999e28 (diff)
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar
guix-patches-a8448da0f4a090818104e64dd79f90b0e50d5e77.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm40
1 files changed, 18 insertions, 22 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 39b194b25e..0a1ace6328 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
@@ -370,39 +370,33 @@ do what is needed for client/server Kerberos authentication based on
(define-public python-keyring
(package
(name "python-keyring")
- (version "21.0.0")
+ (version "22.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "keyring" version))
(sha256
(base32
- "1k0w3yh3fz0qp0cvkxdiinq9jzbrnc6bd88qpjz34x3cgcr94psz"))
- (modules '((guix build utils)))
- (snippet
- ;; https://github.com/jaraco/keyring/issues/414
- '(begin (substitute* "tests/test_packaging.py"
- (("ep, =") "(ep,) =")) #t))))
+ "1pvqc6may03did0iz98gasg7cy4h8ljzs4ibh927bfzda8a3xjws"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- ;; Not clear why this test fails.
- (delete-file "tests/test_packaging.py")
- (substitute* "pytest.ini"
- (("--black ") ""))
- (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"))
+ #t)))))
(native-inputs
- `(("python-pytest" ,python-pytest)
+ `(("python-toml" ,python-toml)
+ ("python-pytest" ,python-pytest)
("python-pytest-checkdocs" ,python-pytest-checkdocs)
("python-pytest-cov" ,python-pytest-cov)
("python-pytest-flake8" ,python-pytest-flake8)
+ ("python-setuptools" ,python-setuptools)
("python-setuptools-scm" ,python-setuptools-scm)))
(propagated-inputs
- `(("python-importlib-metadata" ,python-importlib-metadata)
- ("python-secretstorage" ,python-secretstorage)))
+ `(("python-secretstorage" ,python-secretstorage)))
(home-page "https://github.com/jaraco/keyring")
(synopsis "Store and access your passwords safely")
(description
@@ -1473,14 +1467,14 @@ and Backlog for a list of what is and is not currently supported.")
(define-public python-secretstorage
(package
(name "python-secretstorage")
- (version "3.1.2")
+ (version "3.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "SecretStorage" version))
(sha256
(base32
- "1xmzr0j3066s220bss4nkgqbiwb5k4kkp2rkpqlqwjb5kfc8mnhm"))))
+ "15ginv4gzxrx77n7517xnvf2jcpqc6ran12s951hc85zlr8nqrpx"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; Tests require a running dbus service.
@@ -1561,18 +1555,20 @@ certificates, signing and building trust bundles.")
(define-public python-jeepney
(package
(name "python-jeepney")
- (version "0.4.3")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jeepney" version))
(sha256
- (base32 "0vp3p1lqhqk2kd3254q5sxr50znmm2hmysc8a7g0fr1brihvhy9l"))))
+ (base32 "0mw6ch5s4czpmsiwqwhcidgk27858pl8vlvb7acrxjkm4ribcnbx"))))
(build-system python-build-system)
(native-inputs
`(("python-testpath" ,python-testpath)
("python-tornado" ,python-tornado)
- ("python-pytest" ,python-pytest)))
+ ("python-trio" ,python-trio)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-trio" ,python-pytest-trio)))
(home-page "https://gitlab.com/takluyver/jeepney")
(synopsis "Low-level, pure Python DBus protocol wrapper")
(description