summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 03:14:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:56 -0400
commit9c74e5d566e52d5271d7bdcf7d31ed46df5e944a (patch)
tree8a12ed3fe407f0565699c17caf88685198df2f82 /gnu/packages/python-crypto.scm
parent5df79d1ea84a27afce5487eef888e7371739a519 (diff)
downloadguix-patches-9c74e5d566e52d5271d7bdcf7d31ed46df5e944a.tar
guix-patches-9c74e5d566e52d5271d7bdcf7d31ed46df5e944a.tar.gz
gnu: Remove python2-cryptography.
* gnu/packages/python-crypto.scm (python2-cryptography): Delete variable. (python-cryptography)[properties]: Delete field.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 406e5b685a..c91a247c09 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -488,26 +488,7 @@ libraryā€¯ for Python. The package includes both high level recipes, and low
level interfaces to common cryptographic algorithms such as symmetric ciphers,
message digests and key derivation functions.")
;; Distributed under either BSD-3 or ASL2.0
- (license (list license:bsd-3 license:asl2.0))
- (properties `((python2-variant . ,(delay python2-cryptography))))))
-
-(define-public python2-cryptography
- (let ((crypto (package-with-python2
- (strip-python2-variant python-cryptography))))
- (package/inherit crypto
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; The sanity-check attempts attempts to import the non-existent
- ;; modules "_openssl" and "_padding".
- (delete 'sanity-check))))
- (propagated-inputs
- `(("python2-ipaddress" ,python2-ipaddress)
- ("python2-backport-ssl-match-hostname"
- ,python2-backport-ssl-match-hostname)
- ("python2-enum34" ,python2-enum34)
- ,@(package-propagated-inputs crypto))))))
+ (license (list license:bsd-3 license:asl2.0))))
;; TODO: Make this the default in the next staging cycle.
(define-public python-cryptography-vectors-next