summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-11 15:04:56 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:12:07 -0400
commit94d1992d9ed1e3f3c0cd005a1c54fec7382e3622 (patch)
tree11916edac329fdcb7532b672e6d1e94d1e3b881b /gnu/packages/python-crypto.scm
parentbf7ac629114846121818ad14e1c55db3347d2bd7 (diff)
downloadguix-patches-94d1992d9ed1e3f3c0cd005a1c54fec7382e3622.tar
guix-patches-94d1992d9ed1e3f3c0cd005a1c54fec7382e3622.tar.gz
gnu: python-service-identity: Update to 21.1.0.
* gnu/packages/python-crypto.scm (python-service-identity): Update to 21.1.0. [build-system]: Use pyproject-build-system. [native-inputs]: New field. [propagated-inputs]: Remove python-pyopenssl. Add python-cryptography and python-six.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index b3c9e57d70..220f2b9bcd 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1236,18 +1236,17 @@ derivation function.")
(define-public python-service-identity
(package
(name "python-service-identity")
- (version "18.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "service_identity" version))
- (sha256
- (base32
- "0b9f5qiqjy8ralzgwjgkhx82h6h8sa7532psmb8mkd65md5aan08"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-attrs python-pyasn1 python-pyasn1-modules
- python-pyopenssl))
+ (version "21.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "service-identity" version))
+ (sha256
+ (base32
+ "0d4x84crbz0a17d8gi90z6zlxwm9pslc65rx0cdw2797ra360v3f"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-idna python-pytest))
+ (propagated-inputs (list python-attrs python-cryptography python-pyasn1
+ python-pyasn1-modules python-six))
(home-page "https://service-identity.readthedocs.io/")
(synopsis "Service identity verification for PyOpenSSL")
(description