summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-18 09:54:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-18 09:54:47 +0200
commit92fe25130c1521d3976e1053fc50be38b72ecc55 (patch)
tree4271ed3712ee12310f97ee9fc35cb611e36cda7a /gnu/packages/python-crypto.scm
parentc57b8419f4b9ccd4ee27ed052346f192b9e28366 (diff)
downloadguix-patches-92fe25130c1521d3976e1053fc50be38b72ecc55.tar
guix-patches-92fe25130c1521d3976e1053fc50be38b72ecc55.tar.gz
gnu: python-ecdsa: Actually run the test suite.
* gnu/packages/python-crypto.scm (python-ecdsa)[arguments]: Replace 'check phase. [native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 65594a5aa6..63d3be17c2 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -240,10 +240,16 @@ Python interface around SSH networking concepts.")
(sha256
(base32 "13nx5cbfxc0gnax5zwdmp9xc40qd1llk62mv85jyrvqkbw017ik4"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "pytest"))))))
(propagated-inputs
`(("python-six" ,python-six)))
(native-inputs
- `(("openssl" ,openssl)))
+ `(("openssl" ,openssl)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/warner/python-ecdsa")
(synopsis "ECDSA cryptographic signature library (pure python)")
(description