summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-13 19:33:33 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:12 +0200
commit78c2f6e3ad77821c41b129b95be0ed4225315515 (patch)
tree97f0fbd2b017c3467ed60a84bf08cac0b47d99c9 /gnu/packages/python-crypto.scm
parentb12a916e356ed5b7448d88dfcbf0bc689aa98ca4 (diff)
downloadguix-patches-78c2f6e3ad77821c41b129b95be0ed4225315515.tar
guix-patches-78c2f6e3ad77821c41b129b95be0ed4225315515.tar.gz
gnu: python-pyopenssl: Update to 20.0.1.
* gnu/packages/python-crypto.scm (python-pyopenssl): Update to 20.0.1.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 7d54a15aee..3a201e4095 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -565,14 +565,14 @@ message digests and key derivation functions.")
(define-public python-pyopenssl
(package
(name "python-pyopenssl")
- (version "20.0.0")
+ (version "20.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyOpenSSL" version))
(sha256
(base32
- "1i8ab5zn9i9iq2ksizp3rd42v157kacddzz88kviqw3kpp68xw4j"))))
+ "0labcbh2g0jhgisd79wx9kixmi6fip28096d1xb05fj3jmsiq8sc"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -584,7 +584,7 @@ message digests and key derivation functions.")
;; PyOpenSSL runs tests against a certificate with a fixed
;; expiry time. To ensure successful builds in the future,
;; set the time to roughly the release date.
- (invoke "faketime" "2020-12-01" "py.test" "-v" "-k"
+ (invoke "faketime" "2021-05-01" "py.test" "-v" "-k"
(string-append
;; This test tries to look up certificates from
;; the compiled-in default path in OpenSSL, which