summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2023-05-13 13:31:40 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-22 17:05:22 +0200
commit6ee8b5316cad2fb960227e42f1379b895a6caf5f (patch)
tree997489faf30ccf646c5910b03c40c1baa5610cea /gnu/packages/python-crypto.scm
parentdaeafac0c4b00cb95fbe50372428830f6be1059a (diff)
downloadguix-patches-6ee8b5316cad2fb960227e42f1379b895a6caf5f.tar
guix-patches-6ee8b5316cad2fb960227e42f1379b895a6caf5f.tar.gz
gnu: python-txtorcon: Update to 23.0.0.
* gnu/packages/python-crypto.scm (python-txtorcon): Update to 23.0.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm30
1 files changed, 21 insertions, 9 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 6a7611ccdb..7b2ac2db6e 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1247,22 +1247,33 @@ Password-Authenticated Key Exchange algorithm.")
(define-public python-txtorcon
(package
(name "python-txtorcon")
- (version "19.0.0")
+ (version "23.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "txtorcon" version))
(sha256
(base32
- "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))
- (modules '((guix build utils)))
- (snippet #~(substitute* "txtorcon/controller.py"
- (("from collections import Sequence")
- "from collections.abc import Sequence")))))
+ "09a3k4g90pvs0q006ighka7xic39nnnk9bfrka23g4b8cynzy982"))))
(build-system python-build-system)
(arguments
- ;; The tests fail immediately due to a missing file. Reported upstream:
- ;; <https://github.com/meejah/txtorcon/issues/330>
- (list #:tests? #f))
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'disable-failing-tests
+ (lambda _
+ ;; These tests fail
+ (substitute* "test/test_router.py"
+ (("\\W+def test_countrycode\\(self\\):" all)
+ (string-append
+ " from unittest import skip as _skip\n"
+ " @_skip('Fails during Guix build')\n" all))
+ (("\\W+def test_get_location_private\\(self\\):"
+ all)
+ (string-append
+ " @_skip('Fails during Guix build')\n" all)))
+ ;; This test errors out
+ (substitute* "test/test_util.py"
+ (("\\W+def test_real_addr\\(self\\):" all)
+ (string-append
+ " @_skip('Fails during Guix build')\n" all))))))))
(propagated-inputs (list python-automat
python-idna
python-incremental
@@ -1270,6 +1281,7 @@ Password-Authenticated Key Exchange algorithm.")
python-service-identity
python-twisted
python-zope-interface))
+ (native-inputs (list python-mock))
(home-page "https://github.com/meejah/txtorcon")
(synopsis "Twisted-based Tor controller client")
(description "This package provides a Twisted-based Tor controller client,