summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 22:34:08 +0200
committerMarius Bakke <marius@gnu.org>2020-07-25 16:16:06 +0200
commit6a4c48af6589ae1fcc5db75dfd37c6e28ef6d1ee (patch)
tree815c05ef9d7c0c0c31aa46fb0a606dba294b5115 /gnu/packages/python-crypto.scm
parent4c19be148566c1666996322981980d6c1b82f765 (diff)
downloadguix-patches-6a4c48af6589ae1fcc5db75dfd37c6e28ef6d1ee.tar
guix-patches-6a4c48af6589ae1fcc5db75dfd37c6e28ef6d1ee.tar.gz
gnu: python-cryptography: Update to 3.0.
* gnu/packages/python-crypto.scm (python-cryptography-vectors, python-cryptography): Update to 3.0.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 07d1dd1f1f..41d15f80e1 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -470,14 +470,14 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python-cryptography-vectors
(package
(name "python-cryptography-vectors")
- (version "2.9.2")
+ (version "3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography_vectors" version))
(sha256
(base32
- "1d4iykcv7cn9j399hczlxm5pzxmqy6d80h3j16dkjwlmv3293b4r"))))
+ "0fa26ggksyhknb43cja1g0jwp35qkdbavivdq6yynj1igd2z1vsj"))))
(build-system python-build-system)
(home-page "https://github.com/pyca/cryptography")
(synopsis "Test vectors for the cryptography package")
@@ -492,14 +492,14 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "2.9.2")
+ (version "3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography" version))
(sha256
(base32
- "0af25w5mkd6vwns3r6ai1w5ip9xp0ms9s261zzssbpadzdr05hx0"))))
+ "0lr06a9317n2iwfqwz9mpalqm99acqwk1478arvyj1jj0ay4v4lf"))))
(build-system python-build-system)
(inputs
`(("openssl" ,openssl)))