summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-09 15:37:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-09 15:37:28 +0300
commit5e5c695deabeb8164c86246236e9f483f837f22d (patch)
tree060dc0dbc9e39fe113b67454812f4a91fa8f2cea /gnu/packages/python-crypto.scm
parentab04b2571771f2050fd9e3272bc1079c43e76f3e (diff)
downloadguix-patches-5e5c695deabeb8164c86246236e9f483f837f22d.tar
guix-patches-5e5c695deabeb8164c86246236e9f483f837f22d.tar.gz
gnu: Add python-certipy.
* gnu/packages/python-crypto.scm (python-certipy): New variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c1ff92c452..96837e3cde 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1387,6 +1387,30 @@ use in your tests.")
;; Either license applies.
(license (list license:expat license:asl2.0))))
+(define-public python-certipy
+ (package
+ (name "python-certipy")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "certipy" version))
+ (sha256
+ (base32
+ "0n980gqpzh0fm58h3i4mi2i10wgj606lscm1r5sk60vbf6vh8mv9"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyopenssl" ,python-pyopenssl)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/LLNL/certipy")
+ (synopsis "Utility to create and sign CAs and certificates")
+ (description
+ "Certipy was made to simplify the certificate creation process. To that
+end, certipy exposes methods for creating and managing certificate authorities,
+certificates, signing and building trust bundles.")
+ (license license:bsd-3)))
+
(define-public python-jeepney
(package
(name "python-jeepney")