summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-24 01:58:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-24 01:58:18 +0100
commit4d8f4a3f00268230f879a81f32524fd7c3576ad0 (patch)
tree59afedfc2fb422ef043e6624001290300ed6d800 /gnu/packages/python-crypto.scm
parentc491f7f8de66d0f8386ba6fd7c2da5c3c0d1b24a (diff)
parentdc4851093ce6f3bd2ac71fa189ad87cd740cb656 (diff)
downloadguix-patches-4d8f4a3f00268230f879a81f32524fd7c3576ad0.tar
guix-patches-4d8f4a3f00268230f879a81f32524fd7c3576ad0.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index a38bd00089..1c7640ac5f 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -970,3 +971,33 @@ been constructed to maintain extensive documentation on how to use
(description "This is a set of Python bindings for the scrypt key
derivation function.")
(license license:bsd-2)))
+
+(define-public python-service-identity
+ (package
+ (name "python-service-identity")
+ (version "17.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "service_identity" version))
+ (sha256
+ (base32
+ "1aq24cn3nnsjr9g797dayhx4g653h6bd41ksqhidzq0rvarzn0a0"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-pyasn1-modules" ,python-pyasn1-modules)
+ ("python-pyopenssl" ,python-pyopenssl)))
+ (home-page "https://service-identity.readthedocs.io/")
+ (synopsis "Service identity verification for PyOpenSSL")
+ (description
+ "@code{service_identity} aspires to give you all the tools you need
+for verifying whether a certificate is valid for the intended purposes.
+In the simplest case, this means host name verification. However,
+service_identity implements RFC 6125 fully and plans to add other
+relevant RFCs too.")
+ (license license:expat)))
+
+(define-public python2-service-identity
+ (package-with-python2 python-service-identity))