summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-14 14:04:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-15 09:29:33 +0200
commit3bab95940578e0777d68c204acd14a4307af2450 (patch)
treec42ec319d5f3cf4e2d4e5d3d6ea182c75ed7bd1d /gnu/packages/python-crypto.scm
parent8af48c146dd7506f5c697e6a2981c43cb2885246 (diff)
downloadguix-patches-3bab95940578e0777d68c204acd14a4307af2450.tar
guix-patches-3bab95940578e0777d68c204acd14a4307af2450.tar.gz
gnu: python-jeepney: Update to 0.6.0.
* gnu/packages/python-crypto.scm (python-jeepney): Update to 0.6.0. [native-inputs]: Add python-trio, python-pytest-trio.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 1f491cc972..9613cf3af2 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
@@ -1571,18 +1571,20 @@ certificates, signing and building trust bundles.")
(define-public python-jeepney
(package
(name "python-jeepney")
- (version "0.4.3")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jeepney" version))
(sha256
- (base32 "0vp3p1lqhqk2kd3254q5sxr50znmm2hmysc8a7g0fr1brihvhy9l"))))
+ (base32 "0mw6ch5s4czpmsiwqwhcidgk27858pl8vlvb7acrxjkm4ribcnbx"))))
(build-system python-build-system)
(native-inputs
`(("python-testpath" ,python-testpath)
("python-tornado" ,python-tornado)
- ("python-pytest" ,python-pytest)))
+ ("python-trio" ,python-trio)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-trio" ,python-pytest-trio)))
(home-page "https://gitlab.com/takluyver/jeepney")
(synopsis "Low-level, pure Python DBus protocol wrapper")
(description