summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-04-26 15:20:21 -0400
committerLeo Famulari <leo@famulari.name>2018-04-26 15:41:40 -0400
commit205044b9c181ce6a51010d95c0ccb70c38e489f2 (patch)
tree5ce6806b514c3ab600469cee6ae060864a3b4755 /gnu/packages/python-crypto.scm
parentd1f1a7a0b15bddb05ac4b0e817e9ad855982df11 (diff)
downloadguix-patches-205044b9c181ce6a51010d95c0ccb70c38e489f2.tar
guix-patches-205044b9c181ce6a51010d95c0ccb70c38e489f2.tar.gz
gnu: python-josepy: Update to 1.1.0.
* gnu/packages/python-crypto.scm (python-josepy, python2-josepy): Update to 1.1.0.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index dda1024b39..cdd74d3053 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -717,28 +717,28 @@ Python.")
(define-public python-josepy
(package
(name "python-josepy")
- (version "1.0.1")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "josepy" version))
(sha256
(base32
- "1k0ahzzaq2rrjiifwbhbp7vm8z4zk0ipgiqwicil80kzlf6bhj4z"))))
+ "11khz8malzrv375b27jjkv66z6z6khdx1v5mkkr4vq16gp3n4p7v"))))
(build-system python-build-system)
(arguments
- ;; The tests require pytest >= 3.2, which is not yet packaged.
+ ;; The tests require flake8 >= 3.5, which is not yet packaged.
'(#:tests? #f))
(propagated-inputs
`(("python-cryptography" ,python-cryptography)
("python-pyopenssl" ,python-pyopenssl)
("python-six" ,python-six)))
-;; TODO Enable when we have pytest >= 3.2.
+;; TODO Enable when we have flake8 >= 3.5.
; (native-inputs
; `(("python-coverage" ,python-coverage)
; ("python-flake8" ,python-flake8)
; ("python-isort" ,python-isort)
; ("python-mock" ,python-mock)
-; ("python-pytest" ,python-pytest-3.0)
+; ("python-pytest" ,python-pytest)
; ("python-pytest-cov" ,python-pytest-cov)
; ("python-pytest-cache" ,python-pytest-cache)
; ("python-pytest-flake8" ,python-pytest-flake8)))