summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-07-23 14:03:21 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-29 00:22:01 +0200
commit1b11e894b8b70cb6f8f08f8e11451bb687c7aa0a (patch)
tree0572d5d2b8801d3d859fcaed67917003a83e3b87 /gnu/packages/python-crypto.scm
parent7b7543376bd495c269536d04d97b381ad89da5c4 (diff)
downloadguix-patches-1b11e894b8b70cb6f8f08f8e11451bb687c7aa0a.tar
guix-patches-1b11e894b8b70cb6f8f08f8e11451bb687c7aa0a.tar.gz
gnu: Add python-pgpy.
* gnu/packages/python-crypto.scm (python-pgpy): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 97f5903840..7ea86d1f7b 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1446,3 +1447,30 @@ can decide how long it takes to hash a password and how much memory is required.
data such as API keys, cryptocurrency wallets, or seeds for digital
signatures.")
(license (list license:expat license:asl2.0)))) ; dual licensed
+
+(define-public python-pgpy
+ (package
+ (name "python-pgpy")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PGPy" version))
+ (sha256
+ (base32
+ "0i4lqhzdwkjkim3wab0kqadx28z3r5ixlh6qxj4lif4gif56c0m7"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-singledispatch" ,python-singledispatch)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/SecurityInnovation/PGPy")
+ (synopsis "Python implementation of OpenPGP")
+ (description
+ "Currently, PGPy can load keys and signatures of all kinds in both ASCII
+armored and binary formats.
+
+It can create and verify RSA, DSA, and ECDSA signatures, at the moment. It
+can also encrypt and decrypt messages using RSA and ECDH.")
+ (license license:bsd-3)))