summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-07-13 09:57:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-07-13 11:22:32 -0400
commit08935e5fff2ad9b453aced96f3c7453004945175 (patch)
tree618c4eb2b364af4d7afa590e87bf3061ae897ca6 /gnu/packages/python-crypto.scm
parent4196087f3d6fc254db5b4c47658e5679c835516f (diff)
downloadguix-patches-08935e5fff2ad9b453aced96f3c7453004945175.tar
guix-patches-08935e5fff2ad9b453aced96f3c7453004945175.tar.gz
gnu: Add python-certauth.
* gnu/packages/python-crypto.scm (python-certauth): New variable.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 0134c8c427..d9102adcc9 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -468,6 +469,32 @@ general production use. Include this module and use its backends at your own
risk.")
(license license:expat)))
+(define-public python-certauth
+ (package
+ (name "python-certauth")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "certauth" version))
+ (sha256
+ (base32
+ "1yxqfb5131wahjyw9pxz03bq476rcfx62s6k53xx4cqbzzgdaqkq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyopenssl" ,python-pyopenssl)
+ ("python-tldextract" ,python-tldextract)))
+ (native-inputs
+ `(("python-pytest-cov" ,python-pytest-cov)))
+ (home-page "https://github.com/ikreymer/certauth")
+ (synopsis "Certificate authority creation tool")
+ (description "This package provides a small library, built on top of
+pyOpenSSL, which allows for creating a custom certificate authority (CA)
+certificate, and generating on-demand dynamic host certs using that CA
+certificate. It is most useful for use with a man-in-the-middle HTTPS proxy,
+for example, for recording or replaying web content.")
+ (license license:expat)))
+
(define-public python-certifi
(package
(name "python-certifi")