summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 01:14:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:06 -0400
commit075dbc8734dcfc5843330f7efddc733afb746ace (patch)
treefd5699d7585b7c3df8ab42bfa6345165761780aa /gnu/packages/python-crypto.scm
parentfaa49ec88de38fc37548cc63746542dd21591ebb (diff)
downloadguix-patches-075dbc8734dcfc5843330f7efddc733afb746ace.tar
guix-patches-075dbc8734dcfc5843330f7efddc733afb746ace.tar.gz
gnu: python-keyring: Fix test suite.
[phases]{check}: Provide the tests directory argument to pytest. Ignore project pytest configs and make it verbose. [native-inputs]: Delete python-pytest-checkdocs, python-pytest-cov and python-pytest-flake8.
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 08b86335c0..60879f1c52 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
@@ -351,14 +351,10 @@ do what is needed for client/server Kerberos authentication based on
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest"))
- #t)))))
+ (invoke "pytest" "-vv" "-c" "/dev/null" "tests")))))))
(native-inputs
(list python-toml
python-pytest
- python-pytest-checkdocs
- python-pytest-cov
- python-pytest-flake8
python-setuptools
python-setuptools-scm))
(propagated-inputs