summaryrefslogtreecommitdiff
path: root/gnu/packages/python-compression.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-02-25 14:02:23 +1100
committerLeo Famulari <leo@famulari.name>2021-04-09 16:09:25 -0400
commit875c2ece92536812e827a3ed51fe0aa49c7577f4 (patch)
treeaa05610664a3ef3d12fbcc7623f7d013ccfe11d2 /gnu/packages/python-compression.scm
parenteacfed8b0806e857396e6095825cceedb7c3d5ba (diff)
downloadguix-patches-875c2ece92536812e827a3ed51fe0aa49c7577f4.tar
guix-patches-875c2ece92536812e827a3ed51fe0aa49c7577f4.tar.gz
gnu: Add python-py7zr.
* gnu/packages/python-compression.scm (python-py7zr): New variable.
Diffstat (limited to 'gnu/packages/python-compression.scm')
-rw-r--r--gnu/packages/python-compression.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index bed965f48e..30062f43c5 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sphinx))
@@ -125,6 +126,46 @@ by Partial Matching statistical technique. It is used in RAR and 7-Zip as one o
several possible methods.")
(license license:lgpl2.1+)))
+(define-public python-py7zr
+ (package
+ (name "python-py7zr")
+ (version "0.14.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "py7zr" version))
+ (sha256
+ (base32
+ "1zmgp7yax328fj8yj8pj4l7yh78hp727j6wk12vfi6nmi82wl32i"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-bcj-cffi" ,python-bcj-cffi)
+ ("python-multivolumefile" ,python-multivolumefile)
+ ("python-ppmd-cffi" ,python-ppmd-cffi)
+ ("python-pycryptodome" ,python-pycryptodome)
+ ("python-pyzstd" ,python-pyzstd)
+ ("python-texttable" ,python-texttable)
+ ("python-zstandard" ,python-zstandard)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-setuptools-scm" ,python-setuptools-scm/next)
+ ("python-coverage" ,python-coverage)
+ ("python-coveralls" ,python-coveralls)
+ ("python-libarchive-c" ,python-libarchive-c)
+ ("python-py-cpuinfo" ,python-py-cpuinfo)
+ ("python-pyannotate" ,python-pyannotate)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-benchmark" ,python-pytest-benchmark)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-remotedata" ,python-pytest-remotedata)
+ ("python-pytest-timeout" ,python-pytest-timeout)))
+ (home-page "https://github.com/miurahr/py7zr")
+ (synopsis "7-zip in Python")
+ (description "This package provides py7zr, which implements 7-zip
+archive compression, decompression, encryption and decryption in
+Python.")
+ (license license:lgpl2.1+)))
+
(define-public python-lzo
(package
(name "python-lzo")