summaryrefslogtreecommitdiff
path: root/gnu/packages/python-compression.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-16 00:45:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:33 +0100
commit0ae97f5dd1c6cc2ad8e9f27f62e5a72e0d5fbb4c (patch)
tree1d9d64be060162ea5c256b14d8136a692b3c1169 /gnu/packages/python-compression.scm
parentdb6fb90a1fc29ab8a5fb61483e0e30d74c4eb8d8 (diff)
downloadguix-patches-0ae97f5dd1c6cc2ad8e9f27f62e5a72e0d5fbb4c.tar
guix-patches-0ae97f5dd1c6cc2ad8e9f27f62e5a72e0d5fbb4c.tar.gz
gnu: python2-pytest: Update to 4.6.9.
* gnu/packages/check.scm (python2-pytest): Update to 4.6.9. (python2-pytest-bootstrap)[propagated-inputs]: Add PYTHON2-IMPORTLIB-METADATA-BOOTSTRAP, PYTHON2-PACKAGING-BOOTSTRAP, and PYTHON2-WCWIDTH. Replace PYTHON2-PLUGGY with PYTHON2-PLUGGY-BOOTSTRAP. * gnu/packages/python-compression.scm (python2-zipp-bootstrap): New public variable. * gnu/packages/python-xyz.scm (python2-importlib-resources-bootstrap): New public variable. (python-importlib-metadata)[native-inputs]: Change from PYTHON-PACKAGING to PYTHON-PACKAGING-BOOTSTRAP. [properties]: New field. (python2-importlib-metadata-bootstrap, python2-contextlib2-bootstrap, python2-pluggy-bootstrap): New public variables. (python-packaging)[arguments]: Allow overriding #:tests?. (python2-packaging-bootstrap): New public variable.
Diffstat (limited to 'gnu/packages/python-compression.scm')
-rw-r--r--gnu/packages/python-compression.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 70abc7bad1..7924479185 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -243,6 +244,17 @@ wrapper. It provides a backport of the @code{Path} object.")
("python-unittest2" ,python2-unittest2)
,@(package-native-inputs base))))))
+;; This package is used to bootstrap pytest, via importlib-metadata.
+(define-public python2-zipp-bootstrap
+ (hidden-package
+ (package/inherit
+ python2-zipp
+ (arguments
+ `(#:tests? #f
+ ,@(package-arguments python2-zipp)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python2-setuptools-scm))))))
+
(define-public python-zstandard
(package
(name "python-zstandard")