summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 15:23:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:36 -0400
commitf2be0c5b2b19a4c867906f4ae1b4393d92cc4b08 (patch)
tree194e3ab9e383e5a2453c7074f3cddff9a5c69d63 /gnu/packages/python-check.scm
parentc6c2e3710b91c570fb244e4a5fd3a476ebef33d1 (diff)
downloadguix-patches-f2be0c5b2b19a4c867906f4ae1b4393d92cc4b08.tar
guix-patches-f2be0c5b2b19a4c867906f4ae1b4393d92cc4b08.tar.gz
gnu: python-pytest-shutil: Adjust to use python-path.
* gnu/packages/python-check.scm (python-pytest-shutil) [phases]{use-path-instead-of-path.py}: New phase. [propagated-inputs]: Replace python-path.py with python-path.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f44ab0ca9a..5469200afc 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1080,6 +1080,12 @@ isort.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'use-path-instead-of-path.py
+ ;; path.py is obsolete.
+ (lambda _
+ (substitute* "setup.py"
+ (("'path.py'")
+ "'path'"))))
(add-after 'unpack 'patch-tests
(lambda _
(mkdir "/tmp/bin")
@@ -1087,11 +1093,9 @@ isort.")
(("dirname = '/bin'")
"dirname = '/tmp/bin'")
(("bindir = os.path.realpath\\('/bin'\\)")
- "bindir = os.path.realpath('/tmp/bin')"))
- #t)))))
+ "bindir = os.path.realpath('/tmp/bin')")))))))
(propagated-inputs
- (list python-contextlib2 python-execnet python-pathpy
- python-termcolor))
+ (list python-contextlib2 python-execnet python-path python-termcolor))
(native-inputs
(list python-mock python-pytest python-setuptools-git))
(home-page "https://github.com/manahl/pytest-plugins")