summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-20 23:48:02 +0100
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:32 +0100
commitf1163b8803a1530125b845f6a8a3269e1a29a152 (patch)
tree566d0274e15b2f777b07dba2d459bb598862ac2d /gnu/packages/python-check.scm
parent78c5f162b73b665f7812a63db4e7482cda3c2bfa (diff)
downloadguix-patches-f1163b8803a1530125b845f6a8a3269e1a29a152.tar
guix-patches-f1163b8803a1530125b845f6a8a3269e1a29a152.tar.gz
gnu: Add python-junit-xml.
* gnu/packages/python-check.scm (python-junit-xml): New public variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index cad9a0c94a..e3d2da9b59 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -83,6 +83,39 @@ This package provides seamless integration with coverage.py (and thus pytest,
nosetests, etc...) in Python projects.")
(license license:expat)))
+(define-public python-junit-xml
+ ;; XXX: There are no tags or PyPI releases, so take the latest commit
+ ;; and use the version defined in setup.py.
+ (let ((version "1.9")
+ (commit "4bd08a272f059998cedf9b7779f944d49eba13a6")
+ (revision "0"))
+ (package
+ (name "python-junit-xml")
+ (version (git-version version revision commit))
+ (home-page "https://github.com/kyrus/python-junit-xml")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b8kbjhk3j10rk0vcniy695m3h43yip6y93h1bd6jjh0cp7s09c7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (synopsis "Create JUnit XML test results")
+ (description
+ "This package provides a Python module for creating JUnit XML test
+result documents that can be read by tools such as Jenkins or Bamboo.")
+ (license license:expat))))
+
(define-public python-vcrpy
(package
(name "python-vcrpy")