summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-09-11 23:22:10 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-09-13 00:10:35 +0900
commite2fb29b792cb9cf2416c6292ece56c09a89bdcc9 (patch)
treefac21d929bd9d1ff8faebead3a755b28b8f66e03 /gnu/packages/python-check.scm
parent01a53e0b378aca02c429ebfb5018237867a6d024 (diff)
downloadguix-patches-e2fb29b792cb9cf2416c6292ece56c09a89bdcc9.tar
guix-patches-e2fb29b792cb9cf2416c6292ece56c09a89bdcc9.tar.gz
gnu: python-pytest-virtualenv: Enable tests.
* gnu/packages/python-check.scm (python-pytest-virtualenv) [phases]{patch-virtualenv-executable}: New phase. [propagated-inputs]: Move python-virtualenv from here... [inputs]: ...to here.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 676dae5430..b8aaef9b77 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -226,11 +227,27 @@ testing framework.")
(base32
"03w2zz3crblj1p6i8nq17946hbn3zqp9z7cfnifw47hi4a4fww12"))))
(build-system python-build-system)
- (arguments '(#:tests? #f)) ; one test fails; can't find virtualenv
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Reference the virtualenv executable directly, to avoid the need
+ ;; for PYTHONPATH, which gets cleared when instantiating a new
+ ;; virtualenv with pytest-virtualenv.
+ (add-after 'unpack 'patch-virtualenv-executable
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((virtualenv (assoc-ref inputs "python-virtualenv"))
+ (virtualenv-bin (string-append virtualenv
+ "/bin/virtualenv")))
+ (substitute* "pytest_virtualenv.py"
+ (("^DEFAULT_VIRTUALENV_FIXTURE_EXECUTABLE.*$")
+ (format #f "DEFAULT_VIRTUALENV_FIXTURE_EXECUTABLE = '~a'"
+ virtualenv-bin)))
+ #t))))))
(propagated-inputs
- `(("python-virtualenv" ,python-virtualenv)
- ("python-pytest-shutil" ,python-pytest-shutil)
+ `(("python-pytest-shutil" ,python-pytest-shutil)
("python-pytest-fixture-config" ,python-pytest-fixture-config)))
+ (inputs
+ `(("python-virtualenv" ,python-virtualenv)))
(native-inputs
`(("python-mock" ,python-mock)
("python-pytest" ,python-pytest)