summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-30 10:27:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-30 10:27:55 -0400
commite2c58b91500b4df0979a6e823fc66b0ed1da2d84 (patch)
treea2076d146c0e551b96586af22eaa7a4ef4157735 /gnu/packages/python-check.scm
parent7b59508ca711d1fe299de3f8d9710da36aeb6829 (diff)
downloadguix-patches-e2c58b91500b4df0979a6e823fc66b0ed1da2d84.tar
guix-patches-e2c58b91500b4df0979a6e823fc66b0ed1da2d84.tar.gz
gnu: Add python-pytest-repeat.
* gnu/packages/python-check.scm (python-pytest-repeat): New variable.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index de0a98978a..d5ebb918b8 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -553,6 +553,35 @@ developers to control unit tests that require access to data from the
internet.")
(license license:bsd-3)))
+(define-public python-pytest-repeat
+ (package
+ (name "python-pytest-repeat")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-repeat" version))
+ (sha256
+ (base32 "0nxdbghjz6v4xidl5ky9wlx6z4has3vygj5r7va5ccdb8nbjilsw"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/pytest-dev/pytest-repeat")
+ (synopsis "Pytest plugin for repeating tests")
+ (description "@code{pytest-repeat} is a plugin for Pytest that makes it
+enables repeating a single test, or multiple tests, a specific number of
+times.")
+ (license license:mpl2.0)))
+
(define-public python-pytest-mpl
(package
(name "python-pytest-mpl")