summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/python-check.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
downloadguix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar
guix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5a414e415f..ad41aae34e 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1100,6 +1100,71 @@ also ensuring that the notebooks are running without errors.")
"This pytest plugin provides fixtures to simplify Flask app testing.")
(license license:expat)))
+(define-public python-pytest-console-scripts
+ (package
+ (name "python-pytest-console-scripts")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-console-scripts" version))
+ (sha256
+ (base32
+ "073l2cz11013dl30zjr575ms78j9b2bsbdl1w0gmig37spbkh8aa"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "--verbose"
+ ;; This one test fails because of PATH assumptions
+ "-k" "not test_elsewhere_in_the_path")))))))
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/kvas-it/pytest-console-scripts")
+ (synopsis "Pytest plugin for testing console scripts")
+ (description
+ "This package provides a pytest plugin for testing console scripts.")
+ (license license:expat)))
+
+(define-public python-pytest-tornasync
+ (package
+ (name "python-pytest-tornasync")
+ (version "0.6.0.post2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-tornasync" version))
+ (sha256
+ (base32
+ "0pdyddbzppkfqwa7g17sdfl4w2v1hgsky78l8f4c1rx2a7cvd0fp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false ; TODO: fails at "from test import MESSAGE, PAUSE_TIME"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "--verbose")))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://github.com/eukaryote/pytest-tornasync")
+ (synopsis "Pytest plugin for testing Tornado code")
+ (description
+ "This package provides a simple pytest plugin that provides some helpful
+fixtures for testing Tornado (version 5.0 or newer) apps and easy handling of
+plain (undecoratored) native coroutine tests.")
+ (license license:expat)))
+
(define-public python-pytest-env
(package
(name "python-pytest-env")